Email Sending Delayed
Incident Report for Handshake
Resolved
This incident has been resolved.
Posted May 29, 2021 - 12:57 PDT
Identified
Email delivery is delayed due to an outage in a third-party service. We are monitoring closely.
Posted May 29, 2021 - 09:57 PDT
This incident affected: UK (Handshake for EDU Partners - UK, Handshake for Employers - UK).