High Error Rate
Incident Report for Handshake
Resolved
This incident has been resolved.
Posted Feb 07, 2020 - 11:48 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 07, 2020 - 11:42 PST
This incident affected: Handshake Application.