Processing Delays
Incident Report for Handshake
Resolved
This incident has been resolved.
Posted Jun 02, 2020 - 12:33 PDT
Investigating
Some background processing within the Handshake application may experience delays over the next 20-30 minutes. All web traffic to the application should be unaffected during this time.
Posted Jun 02, 2020 - 12:16 PDT
This incident affected: Handshake Application.