Degraded EDU user experience
Incident Report for Handshake
Resolved
This incident has been resolved.
Posted Feb 08, 2023 - 10:14 PST
Update
We are continuing to investigate this issue.
Posted Feb 08, 2023 - 10:02 PST
Investigating
We are aware of and investigating a service outage affecting certain features for Career Fairs.
Posted Feb 08, 2023 - 09:57 PST
This incident affected: US (Handshake for EDU Partners - US).