Application unavailable
Incident Report for Handshake
Resolved
This incident has been resolved.

At 8:10am PT this morning, Handshake experienced an overload of traffic in a sub-system responsible for communicating with the main database. It took approximately 60 minutes to pinpoint that as the root issue. Once identified, at 9:20am PT, Handshake engineers added more resources to that sub-system which had an immediate positive effect. The team is already working on putting additional monitoring and alerting in place to prevent this from happening in the future. We're very sorry for any issues caused by this incident.
Posted Oct 05, 2020 - 09:38 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 05, 2020 - 09:32 PDT
Update
We are continuing to investigate this issue.
Posted Oct 05, 2020 - 09:17 PDT
Investigating
We are currently investigating this issue.
Posted Oct 05, 2020 - 08:26 PDT
This incident affected: Handshake Application, Insights Reporting, and Handshake Importer.