Limited Applicant page functionality

Incident Report for Handshake

Resolved

As of 2:37 pm PT, a fix has been implemented, and we can now confirm the issue has been resolved. We want to reassure our users that their data was not lost and all application candidate data remains accessible
Posted Sep 05, 2025 - 14:48 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 05, 2025 - 14:33 PDT

Identified

Apologies from the Handshake Team. We are aware of the current issues with the Applicant page, and we are actively working to resolve them. We will provide updates as soon as possible.
Posted Sep 05, 2025 - 14:12 PDT
This incident affected: US (Handshake for Employers - US) and UK/EU (Handshake for Employers - EU).