Degraded Performance for Employers
Incident Report for Handshake
Resolved
This incident has been resolved.
Posted Sep 16, 2020 - 10:23 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 16, 2020 - 09:39 PDT
Investigating
We are aware of an issue causing some pages to perform slowly and are actively investigating.
Posted Sep 16, 2020 - 08:47 PDT
This incident affected: Handshake Application.