US: Locations missing for some jobs

Incident Report for Handshake

Resolved

This incident has been resolved.
Posted Aug 23, 2024 - 03:45 PDT

Update

We are continuing to work on a fix for this issue.
Posted Aug 22, 2024 - 16:09 PDT

Update

We are continuing to work on a fix for this issue.
Posted Aug 22, 2024 - 15:38 PDT

Update

We are continuing to work on a fix for this issue.
Posted Aug 22, 2024 - 13:36 PDT

Update

We are continuing to work on a fix for this issue.
Posted Aug 22, 2024 - 12:37 PDT

Update

We are continuing to work on a fix for this issue.
Posted Aug 22, 2024 - 11:43 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 22, 2024 - 10:43 PDT

Update

Investigation continues.
Posted Aug 22, 2024 - 10:19 PDT

Update

Investigation continues into this issue.
Posted Aug 22, 2024 - 09:46 PDT

Investigating

We are currently investigating this issue.
Posted Aug 22, 2024 - 09:03 PDT
This incident affected: US (Handshake for Students - US) and UK/EU (Handshake for Students - EU).