Degraded Performance
Incident Report for Handshake
Resolved
This incident has been resolved.
Posted Jul 29, 2020 - 14:06 PDT
Investigating
We are currently investigating this issue.
Posted Jul 29, 2020 - 13:39 PDT
This incident affected: Handshake Application.