Delayed search result updates
Incident Report for Handshake
Resolved
The issue causing delays in search results has now been resolved. Our team will continue to monitor and implement any updates necessary to ensure stability.
Posted Mar 18, 2024 - 19:58 PDT
Monitoring
We have implemented a fix to mitigate the issue and are continuing to monitor. Please expect some delays for search related updates until we are fully recovered.
Posted Mar 18, 2024 - 19:15 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 18, 2024 - 15:01 PDT
Investigating
We are experiencing delays reflecting new or updated objects (e.g. jobs, events) in search results. Please allow more time for your updates to display in product. Our engineering team is actively investigating the issue.
Posted Mar 18, 2024 - 12:57 PDT
This incident affected: US (Handshake for Students - US, Handshake for EDU Partners - US, Handshake for Employers - US).