Degraded Performance
Incident Report for Handshake
Resolved
The incident has been resolved. Our team will continue to monitor.
Posted Sep 22, 2022 - 07:37 PDT
Investigating
We are investigating an incident affecting loading pages on the Handshake application and we will provide updates here soon.
Posted Sep 22, 2022 - 07:20 PDT
This incident affected: US (Handshake for EDU Partners - US, Handshake for Employers - US) and UK/EU (Handshake for EDU Partners - EU, Handshake for Employers - EU).