Insights Performance
Incident Report for Handshake
Resolved
This incident has been resolved.
Posted Oct 30, 2019 - 15:43 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 30, 2019 - 12:01 PDT
Update
We are continuing to investigate this issue.
Posted Oct 30, 2019 - 10:56 PDT
Investigating
We are currently investigating this issue.
Posted Oct 30, 2019 - 10:10 PDT
This incident affected: Insights Reporting.