Degraded Performance - Email Links
Incident Report for Handshake
Resolved
The incident has been resolved. Our team will work to provide additional information and support to affected users.
Posted Jun 22, 2022 - 15:54 PDT
Monitoring
A fix for the email links issue has been implemented. Links in the impacted emails should be working again. We continue to monitor results and affected email service.
Posted Jun 22, 2022 - 15:46 PDT
Update
Users are experiencing issues with links within emails. We have identified the issue and are working on a resolution.
Posted Jun 22, 2022 - 15:35 PDT
Identified
Users are experiencing issues with new user account email confirmation links. We have identified the issue and are working on a resolution.
Posted Jun 22, 2022 - 15:31 PDT
Investigating
Users are experiencing issues with new account creation email links. We are actively investigating the issue.
Posted Jun 22, 2022 - 15:16 PDT
This incident affected: US (Handshake for Students - US, Handshake for EDU Partners - US, Handshake for Employers - US).