Degraded Performance
Incident Report for Handshake
Resolved
This incident has been resolved.
Posted Jun 04, 2020 - 19:44 PDT
Identified
We are aware of an issue causing some pages to perform slowly. We have identified the issue and are working to resolve this.
Posted Jun 04, 2020 - 12:14 PDT
This incident affected: Handshake Application.