Degraded Performance
Incident Report for Handshake
Resolved
This incident has been resolved.
Posted Jun 02, 2020 - 20:12 PDT
Investigating
We are aware of an issue causing some pages to perform slowly and are actively investigating.
Posted Jun 02, 2020 - 13:56 PDT
This incident affected: Handshake Application.