Insights Performance
Incident Report for Handshake
Resolved
This incident has been resolved.
Posted Oct 29, 2019 - 15:16 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 29, 2019 - 14:54 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 29, 2019 - 12:07 PDT
This incident affected: Handshake Application.