Degraded Performance
Incident Report for Handshake
Resolved
The incident has been resolved.
Posted Mar 17, 2021 - 11:27 PDT
Identified
We are experiencing intermittent latency on our platform due to underlying issues with our cloud service provider. We are monitoring and working with the provider to resolve the issue.
Posted Mar 17, 2021 - 10:46 PDT
This incident affected: US (Importer - US).