Email Sending Delays
Incident Report for Handshake
Resolved
This incident has been resolved.
Posted Dec 09, 2019 - 16:17 PST
Monitoring
Our email provider has implemented a fix and we are monitoring the results.
Posted Dec 09, 2019 - 15:15 PST
Identified
Our upstream email provider has acknowledged the incident and is investigating the issue.
Posted Dec 09, 2019 - 14:10 PST
Investigating
We are experiencing an issue with our upstream email provider. Some emails may be temporarily delayed in sending.
Posted Dec 09, 2019 - 14:08 PST
This incident affected: Handshake Application.