Email outage
Incident Report for Handshake
Resolved
This incident has been resolved.
Posted Feb 12, 2024 - 11:23 PST
Update
We are continuing to monitor for any further issues.
Posted Feb 12, 2024 - 11:22 PST
Update
Emails are sending successfully, though emails may be delayed due to a backlog needing to be delivered. We are continuing to monitor the situation with our email service provider.
Posted Feb 12, 2024 - 10:00 PST
Monitoring
Email send rates have improved, though we continue to see a small percentage of failures. We are continuing to monitor.
Posted Feb 12, 2024 - 09:21 PST
Identified
We are currently experiencing issues sending emails from the Handshake platform due to an incident with an upstream service provider.
Posted Feb 12, 2024 - 08:42 PST
This incident affected: US (Handshake for Students - US, Handshake for EDU Partners - US, Handshake for Employers - US, Importer - US).