Phone verification service degradation

Incident Report for Handshake

Resolved

Resolving this as phone verification has recovered
Posted Oct 20, 2025 - 15:02 PDT

Update

Phone verification has mostly recovered. However our downstream services still are reporting some degradation. We are continuing to monitor.
Posted Oct 20, 2025 - 13:58 PDT

Update

We are seeing improved performance with phone verification. We are continuing to monitor.
Posted Oct 20, 2025 - 12:31 PDT

Monitoring

We're currently experiencing an issue affecting our phone verification process due to an outage with one of our third-party providers.
Posted Oct 20, 2025 - 11:18 PDT
This incident affected: US (Handshake for Students - US) and UK/EU (Handshake for Students - EU).